Ignore main keyboard to avoid bug with acute accents

Announcements, general discussion
Post Reply
xek2007
Posts: 2
Joined: 21 Nov 2021, 12:19

Ignore main keyboard to avoid bug with acute accents

Post by xek2007 » 21 Nov 2021, 12:30

Hello, first of all thank you for this application and the support you provide for it.
Recently I got a wireless numpad. My purpose is to use it as some kind of "Stream Deck", to be able to link different actions to each one of the keys. I have installed HID Macros and so far I was able to get what I was looking for. I have just associated different actions to each key of the numpad and it works as expected, just been triggered by the external numpad and not by my main keyboard.
The only problem I have found, and from what I have been researching on this forum it's something known and not planned to be fixed is that when I try to use acute accents (for Spanish language) when running HID Macros they don't show up and it just displays "´´" followed by the vowel, instead of the vowel with the acute accent.
As I know it's not planned to be fixed, I would like to find a different approach. As I just want to use HID Macros to perform actions when I press the keys from the external wireless numpad, I would like to know if there is any way to make HID Macros "ignore" my main keyboard, and just work when I input something from the external keyboard. That would make that whenever I use my main keyboard to type something, include vowels with acute accents, HID Macros wouldn't be activated for that keyboard, therefore it wouldn't "interrupt" the regular use of the keyboard, and just be active whenever I use the numpad.
Not sure if that option is possible somehow. I would just like that HID Macros doesn't detect the input from my main keyboard and just from the numpad. Is this possible? Is there any possible workaround for this, so that I can avoid the bug with the acute accents?
Thanks in advance!

admin
Site Admin
Posts: 725
Joined: 01 Nov 2010, 13:00
Location: Prague, Czech republic
Contact:

Re: Ignore main keyboard to avoid bug with acute accents

Post by admin » 22 Nov 2021, 08:53

Unfortunately not. Hidmacros can't "hook" only one keyboard
Petr Medek
LUAmacros author

xek2007
Posts: 2
Joined: 21 Nov 2021, 12:19

Re: Ignore main keyboard to avoid bug with acute accents

Post by xek2007 » 22 Nov 2021, 10:37

admin wrote:
22 Nov 2021, 08:53
Unfortunately not. Hidmacros can't "hook" only one keyboard
Ok, thank you for your reply. Is there no other possible workaround to fix this bug, then? I have been searching through this forum and other places but didn't find a fix. I really like the application, but it gets hard to keep it running in the background if you are giving a normal use of the keyboard in a different language. Thank you anyways!

Post Reply